aboutsummaryrefslogtreecommitdiff
path: root/packages/darwin_pkg/noncvs
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2003-09-17 13:38:41 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2003-09-17 13:38:41 +0000
commite79a1e91d1eceec887fc7213831e130e918daed3 (patch)
tree615780892ed1a6bd50d36ec2e99143dfa60fa2a1 /packages/darwin_pkg/noncvs
parent3625ae77b08ed59e003f251de252ac511bf1d7b1 (diff)
updated installer with pretty pictures; added a noncvs package for random binaries from the net
svn path=/trunk/; revision=989
Diffstat (limited to 'packages/darwin_pkg/noncvs')
-rw-r--r--packages/darwin_pkg/noncvs/Makefile36
-rw-r--r--packages/darwin_pkg/noncvs/Welcome.html27
-rw-r--r--packages/darwin_pkg/noncvs/pd-noncvs.info16
3 files changed, 79 insertions, 0 deletions
diff --git a/packages/darwin_pkg/noncvs/Makefile b/packages/darwin_pkg/noncvs/Makefile
new file mode 100644
index 00000000..7a7547f9
--- /dev/null
+++ b/packages/darwin_pkg/noncvs/Makefile
@@ -0,0 +1,36 @@
+
+current: darwin_pkg
+
+DESTDIR = installroot
+
+PKG_VERSION = $(shell date +20%y.%m.%d)
+PKG_PREFIX = pd-noncvs
+PKG_NAME = $(PKG_PREFIX)-$(PKG_VERSION)
+
+WELCOME_FILE = Welcome.html
+INFO_FILE = $(PKG_NAME).info
+
+clean: darwin_pkg_clean
+
+darwin_pkg_clean:
+ -sudo rm -Rf installroot $(PKG_NAME)*
+ -rm -f *~ 1
+
+# install into MSP's default: /usr/local/lib
+
+darwin_pkg: darwin_pkg_clean
+# set up installroot dir
+ test -d $(DESTDIR)/pd/extra || mkdir -p $(DESTDIR)/pd/extra
+ install -m444 extra/*.pd_darwin $(DESTDIR)/pd/extra
+ cp -rf doc $(DESTDIR)/pd/
+ cp -f pd-noncvs.info $(PKG_NAME).info
+# delete cruft
+ -find $(DESTDIR) -name .DS_Store -delete
+ -rm -f 1
+# set proper permissions
+ sudo chown -R root:staff $(DESTDIR)
+ package $(DESTDIR) $(PKG_NAME).info -d . -ignoreDSStore
+# install pkg docs
+ install -m444 $(WELCOME_FILE) $(PKG_NAME).pkg/Contents/Resources
+ sudo chown -R root:staff $(PKG_NAME).pkg/Contents/Resources
+
diff --git a/packages/darwin_pkg/noncvs/Welcome.html b/packages/darwin_pkg/noncvs/Welcome.html
new file mode 100644
index 00000000..d3eb72d6
--- /dev/null
+++ b/packages/darwin_pkg/noncvs/Welcome.html
@@ -0,0 +1,27 @@
+<HTML>
+<BODY>
+
+<H2>Random Pd Externals</H2>
+
+<P>
+This is a collection of random binaries I found on the net. There is no
+ guarantee that they'll work for you. Consider this stuff very alpha.
+You will inevitably need to install some other stuff to get these working.
+ For example, both GEM and PDP need a number of external libraries. The
+ best way to get these is to use http://fink.sf.net .
+</P>
+
+<P>
+These are the included binary packages:
+<UL>
+<LI>IEMlib 1.12</LI>
+<LI>GEM (G4) CVS 2003.08.06</LI>
+<LI>PDP 0.12.1</LI>
+<LI>pool 0.1.0</LI>
+<LI>vasp 0.1.2</LI>
+<LI></LI>
+</UL>
+</P>
+
+</BODY>
+</HTML> \ No newline at end of file
diff --git a/packages/darwin_pkg/noncvs/pd-noncvs.info b/packages/darwin_pkg/noncvs/pd-noncvs.info
new file mode 100644
index 00000000..00784cc5
--- /dev/null
+++ b/packages/darwin_pkg/noncvs/pd-noncvs.info
@@ -0,0 +1,16 @@
+Title Pd Externals not in CVS
+Version MSP standard paths
+Description This is an informal collection of binaries found on the web.
+DefaultLocation /usr/local/lib
+DeleteWarning
+
+### Package Flags
+
+NeedsAuthorization YES
+Required NO
+Relocatable YES
+RequiresReboot NO
+UseUserMask YES
+OverwritePermissions NO
+InstallFat NO
+RootVolumeOnly NO