aboutsummaryrefslogtreecommitdiff
path: root/packages/linux_make
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2012-02-11 15:02:28 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2012-02-11 15:02:28 +0000
commit7480c6e23b61e7cf4c935c5871a03ae284f3d88d (patch)
tree4bb943abb7995d175369a637f350a7845f8d72f0 /packages/linux_make
parent54d6d4a349d0f0022d079f11216f31334e2cb2b0 (diff)
make find statements handle paths with spaces in them
svn path=/trunk/; revision=15959
Diffstat (limited to 'packages/linux_make')
-rwxr-xr-xpackages/linux_make/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/packages/linux_make/Makefile b/packages/linux_make/Makefile
index 696c0e5e..d2d60d11 100755
--- a/packages/linux_make/Makefile
+++ b/packages/linux_make/Makefile
@@ -175,9 +175,9 @@ deb: $(bindir)
# sanitize permissions
chmod -R go-w $(DESTDIR)
chmod -R a+r $(DESTDIR)
- find $(DESTDIR) -name \*.pd_linux | xargs chmod a-x
- find $(DESTDIR) -name \*.pd | xargs chmod a-x
- find $(DESTDIR) -type d | xargs chmod a+x
+ find $(DESTDIR) -name \*.pd_linux -print0 | xargs -0 chmod a-x
+ find $(DESTDIR) -name \*.pd -print0 | xargs -0 chmod a-x
+ find $(DESTDIR) -type d -print0 | xargs -0 chmod a+x
fakeroot dpkg-deb --build $(DESTDIR) $(packages_src)/linux_make/$(PACKAGE_NAME).deb