aboutsummaryrefslogtreecommitdiff
path: root/packages/linux_make
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2011-11-16 16:57:18 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2011-11-16 16:57:18 +0000
commit96e0cea2e3cf39a0ed3d92aa0b69e5acebb93c22 (patch)
tree329ac7c02c02ba0123a3c8e8cb6dd54d6bafb48f /packages/linux_make
parent8b0a0bfca0ba5d6fa772cc8ed92851494d15103d (diff)
streamlined global debug flags and added -fno-inline-functions for valgrind
svn path=/trunk/; revision=15771
Diffstat (limited to 'packages/linux_make')
-rwxr-xr-xpackages/linux_make/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/packages/linux_make/Makefile b/packages/linux_make/Makefile
index f7372d0e..80b06617 100755
--- a/packages/linux_make/Makefile
+++ b/packages/linux_make/Makefile
@@ -32,7 +32,8 @@ endif
#STRIP = strip --strip-unneeded -R .note -R .comment
STRIP = echo
-OPT_CFLAGS = -g
+DEBUG_CFLAGS = -g -fno-inline-functions -fno-omit-frame-pointer -DDEBUG_SOUNDFILE
+OPT_CFLAGS =
TARGET_PLATFORM := $(shell uname -m)
ifeq ($(TARGET_PLATFORM),i686)
@@ -47,6 +48,8 @@ ifeq ($(TARGET_PLATFORM),ppc)
OPT_CFLAGS += -pipe -fsigned-char -mpowerpc
endif
+OPT_CFLAGS += $(DEBUG_CFLAGS)
+
# lots more here: http://www.gentoo.se/docs/doc-cflags.php
# these are sent to all of the various Makefiles so that they all copy their