aboutsummaryrefslogtreecommitdiff
path: root/packages/linux_make
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux_make')
-rwxr-xr-xpackages/linux_make/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/packages/linux_make/Makefile b/packages/linux_make/Makefile
index f7372d0e..80b06617 100755
--- a/packages/linux_make/Makefile
+++ b/packages/linux_make/Makefile
@@ -32,7 +32,8 @@ endif
#STRIP = strip --strip-unneeded -R .note -R .comment
STRIP = echo
-OPT_CFLAGS = -g
+DEBUG_CFLAGS = -g -fno-inline-functions -fno-omit-frame-pointer -DDEBUG_SOUNDFILE
+OPT_CFLAGS =
TARGET_PLATFORM := $(shell uname -m)
ifeq ($(TARGET_PLATFORM),i686)
@@ -47,6 +48,8 @@ ifeq ($(TARGET_PLATFORM),ppc)
OPT_CFLAGS += -pipe -fsigned-char -mpowerpc
endif
+OPT_CFLAGS += $(DEBUG_CFLAGS)
+
# lots more here: http://www.gentoo.se/docs/doc-cflags.php
# these are sent to all of the various Makefiles so that they all copy their