aboutsummaryrefslogtreecommitdiff
path: root/packages/linux_make
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2011-10-05 05:12:21 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2011-10-05 05:12:21 +0000
commitced4624dae15ead098995a151440c1d80d355a44 (patch)
tree86200f4a0678c5b1ccf4afefae84a7b55f871cbe /packages/linux_make
parent6bfe781ef0e44ac0aae8939e3f292907ad4d9b2c (diff)
enable setting STRIP from the global package-specific Makefile and set STRIP=echo to keep debug symbols
svn path=/trunk/; revision=15506
Diffstat (limited to 'packages/linux_make')
-rwxr-xr-xpackages/linux_make/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/packages/linux_make/Makefile b/packages/linux_make/Makefile
index e6033d6c..d34ca7d6 100755
--- a/packages/linux_make/Makefile
+++ b/packages/linux_make/Makefile
@@ -28,6 +28,10 @@ else
prefix = /usr/local
endif
+# to control whether the debug symbols are kept
+#STRIP = strip --strip-unneeded -R .note -R .comment
+STRIP = echo
+
OPT_CFLAGS = -g
TARGET_PLATFORM := $(shell uname -m)
@@ -52,7 +56,8 @@ DEST_PATHS = BUILDLAYOUT_DIR=$(BUILDLAYOUT_DIR) \
DESTDIR=$(DESTDIR) \
prefix=$(prefix) \
OPT_CFLAGS="$(OPT_CFLAGS)" \
- UNAME=$(UNAME)
+ UNAME=$(UNAME) \
+ STRIP=$(STRIP)
all:
$(MAKE) -C $(packages_src) $(DEST_PATHS)