aboutsummaryrefslogtreecommitdiff
path: root/packages/win32_inno
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2011-10-05 05:12:21 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2011-10-05 05:12:21 +0000
commitced4624dae15ead098995a151440c1d80d355a44 (patch)
tree86200f4a0678c5b1ccf4afefae84a7b55f871cbe /packages/win32_inno
parent6bfe781ef0e44ac0aae8939e3f292907ad4d9b2c (diff)
enable setting STRIP from the global package-specific Makefile and set STRIP=echo to keep debug symbols
svn path=/trunk/; revision=15506
Diffstat (limited to 'packages/win32_inno')
-rwxr-xr-xpackages/win32_inno/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/packages/win32_inno/Makefile b/packages/win32_inno/Makefile
index a31236ae..0dc5a302 100755
--- a/packages/win32_inno/Makefile
+++ b/packages/win32_inno/Makefile
@@ -13,6 +13,10 @@ BUILDLAYOUT_DIR = $(cvs_root_dir)/packages
include $(BUILDLAYOUT_DIR)/Makefile.buildlayout
+# to control whether the debug symbols are kept
+#STRIP = strip --strip-unneeded -R .note -R .comment
+STRIP = echo
+
OPT_CFLAGS = -g
# compile for pentium4 so we can use SSE2
@@ -27,7 +31,8 @@ DEST_PATHS = BUILDLAYOUT_DIR=$(BUILDLAYOUT_DIR) \
DESTDIR=$(DESTDIR) \
prefix=$(prefix) \
OPT_CFLAGS="$(OPT_CFLAGS)" \
- UNAME=$(UNAME)
+ UNAME=$(UNAME) \
+ STRIP="$(STRIP)"
PD_INNO_SETUP = pd-inno.iss