aboutsummaryrefslogtreecommitdiff
path: root/src/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/configure.ac b/src/configure.ac
index c36746e..ca98ab4 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -66,9 +66,12 @@ dnl Replace `main' with a function in -lm:
AC_CHECK_LIB(m, main)
dnl Replace `main' with a function in -lpthread:
dnl AC_CHECK_LIB(pthread, main)
-dnl Replace `main' with a function in -lstk:
+dnl Replace `main' with a function in -lfftw3:
AC_CHECK_LIB(fftw3, fftw_destroy_plan)
+dnl for soundfile reading (and writing, if we do that...)
+AC_CHECK_LIB(sndfile, sf_close)
+
if test "x$with_pd" != "x"; then
if test -d "${with_pd}/src"; then
@@ -96,7 +99,7 @@ AC_CHECK_LIB(pd, nullfn)
dnl Checks for header files.
AC_HEADER_STDC
-AC_CHECK_HEADERS(stdlib.h stdio.h string.h math.h time.h sys/time.h fftw3.h)
+AC_CHECK_HEADERS(stdlib.h stdio.h string.h math.h time.h sys/time.h fftw3.h sndfile.h)
dnl Checks for typedefs, structures, and compiler characteristics.
AC_HEADER_TIME