aboutsummaryrefslogtreecommitdiff
path: root/packages/Makefile
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2011-09-25 20:21:11 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2011-09-25 20:21:11 +0000
commit9a1143111aabeedc13ec27b28cc81426f4dbf147 (patch)
tree96e803268203aedc833f0d6c6abfdd3340aba0ca /packages/Makefile
parent46f8a3c341a2481c0ab16873959e15d6676dc9d4 (diff)
add -f to ln to force creation of links so that install targets can install over existing builds (Closes #3413815 from Jacob Lee)
svn path=/trunk/; revision=15344
Diffstat (limited to 'packages/Makefile')
-rw-r--r--packages/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/packages/Makefile b/packages/Makefile
index fa3e2de8..c3cf6c86 100644
--- a/packages/Makefile
+++ b/packages/Makefile
@@ -122,10 +122,10 @@ pd_install: pd
install -d $(DESTDIR)$(libpddir)/startup
# libdir
cd $(DESTDIR)$(libpddir)/startup && \
- ln -s ../extra/libdir/ libdir
+ ln -s -f ../extra/libdir/ libdir
# pdlua
cd $(DESTDIR)$(libpddir)/startup && \
- ln -s ../extra/pdlua/ pdlua
+ ln -s -f ../extra/pdlua/ pdlua
else
#----------------------------------------------------------------------------#
# old build system